(THIS IS WITHOUT BREAKING MIRROR , REPLACE THE HOT SWAP DISK)
Pre activity steps: Take the below command o/p
# lvlnboot –v
#setboot
#pvdisplay -v /dev/disk/disk?? | more
#vgcfgbackup /dev/vg00
#vgexport -p -v -m /tmp/vg00.map /dev/vg00
Replacement steps: (This is for Mirrored alternate boot disk replacement)
Step 1: #pvchange -a N /dev/dsk/disk2_p2 (Deactivate the disk)
Step 2: Then remove the failed disk and replace with a new disk
Stpe 3: #ioscan -m lun
(check the new lun number for new disk)
step 4: #vi /tmp/partfile
3
EFI 500MB
HPUX 100%
HPSP 400MB
(Dont copy paste, edit the file manually)
Step 5: #idisk -wf /tmp/partfile /dev/rdisk/disk32
( Lets consider the new disk lun id as 32)
Step 6 : #insf -e -C disk -I 32
(create a disk file for new lun)
Step 7 : # io_redirect_dsf -d /dev/disk/disk2 -n /dev/disk/disk32
(change the old path to new disk)
Step 8 : # ioscan -funNC disk
(verify the change)
step 9 : #vgcfgrestore -n /dev/vg00 /dev/rdisk/disk2_p2
(restore the VG to the new disk)
step 10 : #pvchange –a y /dev/disk/disk2_p2
(activate the disk)
step 11: #vgchange -a y /dev/vg00
step 12 : #vgsync vg00
(resync the lvols)
step 13: # mkboot -e -l /dev/rdisk/disk2
step 14: # efi_fsinit -d /dev/rdisk/disk2_p1
(initailize the FAT FS on EFI partition)
step 15: # efi_cp -d /dev/rdisk/disk3_p1 -u /EFI/HPUX/AUTO /tmp/auto
(cat /tmp/auto - check the auto file content)
step 16 : #mkboot -a "boot vmunix -lq" /dev/rdisk/disk2
(change the auto file content)
step 17 : # efi_ls -d /dev/rdisk/disk2_p1
step 18 : # efi_ls -d /dev/rdisk/disk??_p3 /EFI/HP
(chk this for primary boot disk , To check whether diag utilities are there on primary boot disk)
step 19 : #dd if=/dev/rdisk/disk3_p3 of=/dev/rdisk/disk2_p3 bs=1024k
(copy the diag utility from primary boot disk to sec boot disk)
step 20 : #lifls -l /dev/rdisk/disk2_p2
step 21 : #setboot -a "lun path of sec disk"
0 Comments